Interswitch Apparent incident with payment processing in Nigeria
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Jul 09, 2021 - 02:58 GMT-03:00
Investigating
We have identified a problem that has led to degraded performance and we are currently investigating this.
Posted Jul 08, 2021 - 21:13 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Payment processors in Nigeria).