[Cellulant] Apparent incident with payment processing in Kenya

Incident Report for Status dLocal

Resolved

This incident has been resolved,
Kenya Payments in CELLULANT are operating correctly.
Posted May 09, 2024 - 07:00 GMT-03:00

Investigating

We have identified some processing issues with CELLULANT in KENYA. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted May 09, 2024 - 04:17 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Kenya - Payment Processors).