COMMERCIAL INTERNATIONAL BANK (EGYPT) S.A.E. incident with payment processing in Egypt

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Apr 20, 2025 - 08:28 GMT-03:00

Investigating

We are currently investigating this issue.
Posted Apr 20, 2025 - 06:19 GMT-03:00
This incident affected: EMEA Payment processing partners (Egypt - Payment Processors).