Niubiz (Perú)- Apparent incident with payment processing in Perú
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Nov 08, 2020 - 10:57 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Nov 08, 2020 - 09:18 GMT-03:00
This incident affected: LATAM Payments processing partners (Payment processing in Perú).