[Interswitch] Apparent incident with payment processing in Nigeria

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Jun 01, 2024 - 05:27 GMT-03:00

Update

We are continuing to investigate this issue.
Posted Jun 01, 2024 - 04:50 GMT-03:00

Investigating

We have identified some processing issues with Micro Finance Banks (Nigeria)
We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Jun 01, 2024 - 03:29 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Nigeria - Payment Processors).