Fawry (Egypt) Payments
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Feb 19, 2021 - 14:23 GMT-03:00
Update
We are continuing to investigate this issue.
Posted Feb 18, 2021 - 10:33 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Feb 17, 2021 - 17:46 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Payment processing in Egypt).