IZIPAY Apparent incident with payment processing in PERU
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Sep 18, 2022 - 11:09 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Sep 18, 2022 - 07:02 GMT-03:00
This incident affected: LATAM Payments processing partners (Payment processors in Perú).