Cashfree (India) UPI urgent maintenance
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Oct 16, 2020 - 10:26 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Oct 16, 2020 - 06:01 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Payment processors in India).